System Requirements for AutoCAD

System requirements for AutoCAD 2019 including Specialized Toolsets
Operating System
  • Microsoft® Windows® 7 SP1 with Update KB4019990 (32-bit & 64-bit)
  • Microsoft Windows 8.1 with Update KB2919355 (32-bit & 64-bit)
  • Microsoft Windows 10 Anniversary Update (64-bit only) (version 1607 or higher)
ProcessorBasic: 2.5–2.9 GHz processor
Recommended: 3+ GHz processor
MemoryBasic: 8 GB
Recommended: 16 GB
Display Resolution

Conventional Displays:
1920 x 1080 with True Color

High Resolution & 4K Displays:
Resolutions up to 3840 x 2160 supported on Windows 10, 64 bit systems (with capable display card)

Display CardBasic: 1 GB GPU with 29 GB/s Bandwidth and DirectX 11 compliant
Recommended: 4 GB GPU with 106 GB/s Bandwidth and DirectX 11 compliant
Disk Space6.0 GB
BrowserGoogle Chrome™ (for AutoCAD Web)
Network

Deployment via Deployment Wizard.

The license server and all workstations that will run applications dependent on network licensing must run TCP/IP protocol.

Either Microsoft® or Novell TCP/IP protocol stacks are acceptable. Primary login on workstations may be Netware or Windows.

In addition to operating systems supported for the application, the license server will run on the Windows Server® 2016, Windows Server 2012, Windows Server 2012 R2, and Windows Server 2008 R2 editions.

Citrix® XenApp™ 7.6, Citrix® XenDesktop™ 7.6.

Pointing DeviceMS-Mouse compliant
.NET Framework.NET Framework Version 4.7
System requirements for AutoCAD 2020 including Specialized Toolsets (Windows)
Operating System
  • Microsoft® Windows® 7 SP1 with Update KB4019990 (64-bit only)
  • Microsoft Windows 8.1 with Update KB2919355 (64-bit only)
  • Microsoft Windows 10 (64-bit only) (version 1803 or higher)
ProcessorBasic: 2.5–2.9 GHz processor
Recommended: 3+ GHz processor
Multiple processors: Supported by the application
MemoryBasic: 8 GB
Recommended: 16 GB
Display ResolutionConventional Displays:
1920 x 1080 with True Color

High Resolution & 4K Displays:
Resolutions up to 3840 x 2160 supported on Windows 10, 64-bit systems (with capable display card)
Display CardBasic: 1 GB GPU with 29 GB/s Bandwidth and DirectX 11 compliant
Recommended: 4 GB GPU with 106 GB/s Bandwidth and DirectX 11 compliant
Disk Space6.0 GB
BrowserGoogle Chrome™ (for AutoCAD web app)
NetworkDeployment via Deployment Wizard.

The license server and all workstations that will run applications dependent on network licensing must run TCP/IP protocol.

Either Microsoft® or Novell TCP/IP protocol stacks are acceptable. Primary login on workstations may be Netware or Windows.

In addition to operating systems supported for the application, the license server will run on the Windows Server® 2016, Windows Server 2012, and Windows Server 2012 R2 editions.

Pointing DeviceMS-Mouse compliant
.NET Framework.NET Framework Version 4.7 or later

*DirectX11 recommended by supported OS

System requirements for AutoCAD 2021 including Specialized Toolsets (Windows)
Operating System64-bit OS that follows Autodesk’s Product Support Lifecycle policy.
ProcessorBasic: 2.5–2.9 GHz processor
Recommended: 3+ GHz processor
Multiple processors: Supported by the application
MemoryBasic: 8 GB
Recommended: 16 GB
Display ResolutionConventional Displays:
1920 x 1080 with True Color

High Resolution & 4K Displays:
Resolutions up to 3840 x 2160 supported on Windows 10, 64-bit systems (with capable display card)
Display CardBasic: 1 GB GPU with 29 GB/s Bandwidth and DirectX 11 compliant
Recommended: 4 GB GPU with 106 GB/s Bandwidth and DirectX 11 compliant
Disk Space7.0 GB
NetworkDeployment via Deployment Wizard.

The license server and all workstations that will run applications dependent on network licensing must run TCP/IP protocol.

Either Microsoft® or Novell TCP/IP protocol stacks are acceptable. Primary login on workstations may be Netware or Windows.

In addition to operating systems supported for the application, the license server will run on Windows® Server 2012 R2, Windows Server 2016, and Windows Server 2019 editions.
Pointing DeviceMS-Mouse compliant
.NET Framework.NET Framework version 4.8 or later
× How can I help you?